ld:未找到框架,Xcode上的颤动错误

I’m trying to build a Flutter App. The app works absolutely fine with Andrioid. But, gives the following error in Xcode build :

ld: framework not found
clang error : linker command failed with exit code 1(use -v to see invocation)

I have also observed that, although i have my Flutter.framework and App.framework in my Flutter folder. It is not shown in Xcode.

我已经尝试了以下解决方案:

1。CD ios Pod Deintegrate扑振清洁颤动跑

  1. Deintegrate和Pod Install / Pod更新

  2. 在构建阶段中加上运行脚本到/ bin / sh“$ flutter_root / packages / flutter_tools / bin / xcode_backend.sh”build

你找到了这个问题的任何解决方案吗?Awais Abbas

回答 1

  1. 赞同 0

    Build设置搜索“其他链接器标志”删除2行:-framework“”

    Hungafl
    它目前写的,你的答案尚不清楚。请EDIT.添加其他详细信息,这些详细信息将帮助别人了解这是如何解决问题的问题。您可以找到有关如何编写好答案的更多信息。community